字符串尾部匹配-指针
【问题描述】
编写一函数int strend(char *s, char *t),如果字符串 t 出现在字符串 s 的尾部,该函数返回1,否则返回0。
【输入形式】
从键盘分行输入两个字符串:s,t
【输出形式】
如果字符串t出现在字符串尾部,输出Yes,否则输出No
【样例输入】
abcdefgh fgh
【样例输出】
Yes
【样例说明】
输入了两个字符串s,t,发现t是在s的尾部,则输出Yes
主函数:
#include<stdio.h>
#include<string.h>
int main() {
int strend(char *s, char *t);
char s[1000], t[1000];
int k;
gets(s);
gets(t);
k=strend(s, t);
if(k==1) {
printf("Yes");
}
else {
printf("No");
}
return 0;
}
int strend(char *s, char *t);
int strend(char *s, char *t) {
int len1, len2, len, i, j, flag = 1;
len1 = strlen(s);
len2 = strlen(t);
len = len1 - len2;
for(i = 0; i < len2; i++) {
j = i + len;
if(*(s + j) == *(t + i)) {
flag *= 1;
}
else {
flag *=0;
}
}
return flag;
}